[renamed] dispatch to emit
ClosedPublic

Authored by appsforartists on Oct 9 2017, 6:47 PM.

Details

Summary

This allows us to use the noun "emission" to refer to a dispatched value, which should make documentation easier to read and write.

Diff Detail

Repository
R13 material-motion/material-motion-js
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
appsforartists created this revision.Oct 9 2017, 6:47 PM
Restricted Application added a reviewer: O2: Material Motion. · View Herald TranscriptOct 9 2017, 6:47 PM
Restricted Application added a project: Material Motion. · View Herald Transcript
Restricted Application added a reviewer: O3: Material JavaScript platform reviewers. · View Herald Transcript
Restricted Application added a reviewer: Material Motion. · View Herald Transcript
Restricted Application completed building Restricted Buildable.Oct 9 2017, 6:50 PM

Is this just renaming and we don't expect any behavior change correct? I'm curious what is the motivation for this.

vietanh accepted this revision.Oct 11 2017, 12:23 AM
This revision is now accepted and ready to land.Oct 11 2017, 12:23 AM

Yeah, it's just a rename. I think it will make the language easier to understand, because it gives us a noun to refer to values emitted from a stream: emission. Because dispatch is both a noun and a verb, it's harder to speak clearly and precisely than emit/emission.

This revision was automatically updated to reflect the committed changes.