[refactored] boolean$.inverted() to `not(boolean$)`
ClosedPublic

Authored by appsforartists on Oct 4 2017, 9:34 PM.

Details

Summary

This simplifies the scope of inverted() and is more readable.

const whenDragIsActive = when(not(dragIsAtRest$));

is easier to read than

const whenDragIsActive = when(dragIsAtRest$.inverted());

Diff Detail

Repository
R13 material-motion/material-motion-js
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
appsforartists created this revision.Oct 4 2017, 9:34 PM
Restricted Application added a reviewer: O2: Material Motion. · View Herald TranscriptOct 4 2017, 9:34 PM
Restricted Application added a project: Material Motion. · View Herald Transcript
Restricted Application added a reviewer: O3: Material JavaScript platform reviewers. · View Herald Transcript
Restricted Application added a reviewer: Material Motion. · View Herald Transcript
Restricted Application completed building Restricted Buildable.Oct 4 2017, 9:36 PM
featherless accepted this revision.Oct 6 2017, 1:52 PM
featherless added a subscriber: featherless.

Nice.

This revision is now accepted and ready to land.Oct 6 2017, 1:52 PM
This revision was automatically updated to reflect the committed changes.