[refactored] offset/scaled/normalizedBy to added/subtracted/multiplied/dividedBy
ClosedPublic

Authored by appsforartists on Sep 19 2017, 9:03 PM.

Details

Summary

The old names were not intuitive (especially normalizedBy). This change makes them easier to find.

I've also added a subtractedBy, because addedBy(value$.scaledBy(-1)) is needlessly verbose.

Finally, I've used addedBy rather than addedTo to keep the names consistent with one another (and to emphasize that the argument value is the second half of any mathematical operation).

Diff Detail

Repository
R13 material-motion/material-motion-js
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
appsforartists created this revision.Sep 19 2017, 9:03 PM
Restricted Application added a reviewer: O2: Material Motion. · View Herald TranscriptSep 19 2017, 9:03 PM
Restricted Application added a project: Material Motion. · View Herald Transcript
Restricted Application added a reviewer: O3: Material JavaScript platform reviewers. · View Herald Transcript
Restricted Application added a reviewer: Material Motion. · View Herald Transcript
Restricted Application failed to build Restricted Buildable!Sep 19 2017, 9:06 PM
featherless accepted this revision.Oct 6 2017, 9:26 AM
featherless added a subscriber: featherless.

👍

This revision is now accepted and ready to land.Oct 6 2017, 9:26 AM
This revision was automatically updated to reflect the committed changes.